Developers Blog

Blog > Rivendell 2.1.4 Release-Candidate Debian/Ubuntu packages

on May 25, 2012

The Rivendell Debian/Ubuntu 2.1.4 packages are available for download and test (and only for test !).

Lucid and sid are not available for moment because of problems on our build platform. We’re working on it.

Source packages are available on http://projects.tryphon.eu/rivendell2-debian.

Test the package

Download these Release-Candidate packages for your distribution and your architecture on http://download.tryphon.eu/debian/.

For example for your Ubuntu Precise amd64 :

wget \
http://download.tryphon.eu/debian/precise/libhpi_4.08.07-1_amd64.deb \
http://download.tryphon.eu/debian/precise/librivendell_2.1.4-1_amd64.deb \
http://download.tryphon.eu/debian/precise/rivendell_2.1.4-1_amd64.deb \
http://download.tryphon.eu/debian/precise/rivendell-server_2.1.4-1_amd64.deb

Manually install these packages. Missing dependencies will be resolved by apt-get in a second step :

sudo dpkg -i *.deb
sudo apt-get install -f

Packages changes

Support for Ubuntu oneiric and precise

Packages are now available for Ubuntu oneiric and precise. The QT build problem is fixed with this configure/acinclude.m4 patch.

Other new patchs

Two other (small) patchs were needed to fix icons and xdg Makefiles.