Bug #1515

Cannot build RivendellBoxes due to rivendell-import dependency failure

Added by Florent Peyraud 6 months ago.

Status:NewStart date:04/16/2017
Priority:HighDue date:
Assignee:Alban Peignier% Done:

0%

Category:-
Target version:-

Description

The build process gives :

err: /Stage[main]/Rivendell::Import/Ruby::Gem[rivendell-import]/Package[rivendell-import]/ensure: change from absent to 1.04 failed: Could not update: Execution of '/usr/bin/gem install -v 1.04 --include-dependencies --no-rdoc --no-ri rivendell-import' returned 1: INFO:  `gem install -y` is now default and will be removed
INFO:  use --ignore-dependencies to install only the gems you list
When you HTTParty, you must party hard!
Building native extensions.  This could take a while...
Building native extensions.  This could take a while...
ERROR:  Error installing rivendell-import:
    public_suffix requires Ruby version >= 2.0.
 at /tmp/puppet/modules/box/manifests/defines/gem.pp:8

Also available in: Atom PDF